Please note, Internet Explorer is NOT a compatible browser with our current version of Moodle. 

Click here for more information